基本的な概念

もしデジタル絵に挑戦するのが初めてなら、このベージが Krita でデジタルお絵描きを始めるにあたって必要な基礎かつ重要な概念について簡単に説明します。

とても長い物ではあるのですが、このページでは Krita の様々なメニューやボタンの機能をかいつまんで、最も重要な機能をざっと紹介します。

ラスターとベクター

Krita がラスターメインのアプリケーションであるとはいえ、いくらかのベクター編集の能力も備えています。もしデジタル絵描きの手法が初めてなら、画像のラスターと ベクター の概念の違いは知っておく必要があります。

デジタルな描画では、画像の基本かつ最小の単位はピクセル(画素)です。基本的に特定の色を表示する点を意味します。ラスター編集はこれらピクセルを操作編集していきます。例えば1ピクセルの黒色のブラシを使って Krita の白いキャンバスに描いたとすると、実際にはブラシの下のピクセルの色を白から黒に変えています。ズームしてブラシの描画をみると色のついた四角い小さなものが多くあることに気づくでしょう、それがピクセルです:

../../_images/Pixels-brushstroke.png

In contrast to raster images, vector graphic images are based on mathematical expressions. They are independent of the pixels. For example, when you draw a rectangle on a vector layer in Krita you are actually drawing paths passing through points that are called nodes, which are located on specific coordinates on the 'x' and 'y' axes. When you re-size or move these points the computer calculates and redraws the path and displays the newly formed shape to you. Hence, you can re-size the vector shape to any extent without any loss in quality. In Krita, everything which is not on a vector layer is raster based.

画像、表示とウィンドウ

お絵描きソフトでは、作業スペースを構成する3つのモノがあります。

画像

一番重要なのが 画像 です。

これはファイルダイアログで開いたり作ったりする画像とは独立したもののことです。Krita は ファイル メニューから新しい画像としてファイルを開いたり、画像をファイルに保存したり、または増分コピーを作ることができます。

レイヤーデータを含む画像、画像とレイヤーの色空間、キャンバスサイズと製作者、作成日や解像度といったのメタ情報。Krita は複数画像を同時に開き、ウィンドウ メニューから切り替えることができます。

この画像はハードドライブ上の作業中の複製であるので、ちょっとした多くの方法で保存することができます:

新規作成

新しい画像を作ります。保存 を押すと、ハードドライブにファイルを保存します。

開く...

既にある画像の内部コピーを作成します。保存 を押すと、作業中の複製で既にある元の画像を上書きします。

既存のドキュメントを無題のドキュメントとして開く...

開く... と似ていますが、保存 では保存する場所を尋ね、新しい複製を作成します。これは他のソフトで言う インポート... に近いです。

増分バージョンを保存

既存のドキュメントを無題のドキュメントとして開く... と似ていますが、選択された画像でのみ行います。

増分バックアップを保存

現在のファイルのスナップショットをバージョン番号のついたファイルを新しく作ることで簡単に行います。

これらのオプションはファイル間を頻繁に切り替える、何かした時のためにバックアップを取るような生産作業をする人にはとても良い選択肢です。Krita はまた自動保存、ファイルのバックアップクラッシュリカバリの形でファイルバックアップの仕組みがあります。これらの機能は全般設定のところで設定できます。

画像は 表示 を通して見ています。

ビュー

表示とは画像が乗ったウィンドウのことです。Krita は複数視点を持つことができ、ズームや回転、ミラーといった視点を変えることができ、画像を編集することなく色を調節することができます。これはアーティストにとってはとても有用で、画像の見方を変えることは片側に寄っているというようなミスを調べるのによく使われる方法です。M キーを使うミラーはそうしたゆがみを簡単に見分けることができます。

もしあるカーブを描くのに手こずっているなら回転を使うのを楽しめるでしょう。それにもちろん、ラフでも精度を求める時でも拡大することも縮小することもできます。

../../_images/Krita_multiple_views.png

同じ画像のマルチビュー

Krita のマルチビューは ウィンドウ ‣ 新しいビュー ‣ 画像名 で可能です。切り替えは ウィンドウ メニューか、ショートカットキー Ctrl + Tab、または 設定サブウィンドウ モードになっていれば ウィンドウ ‣ 並べて表示 からできます。

ドッカー

ドッカーとは Krita のインターフェース で使われる小さいサブウィンドウのことです。色選択、レイヤーパネル、ツールのオプションといった便利なツールを含んでいます。

../../_images/Dockers.png

上の画像が Krita で使われるドッカーの例です。

すべてのビューやドッカーは ウィンドウ の中に格納されています。

ウィンドウ

もしコンピュータを使ったことがあるなら、ウィンドウが何かわかるでしょう: プログラムで使われる大きな入れものです。

Krita で複数ウィンドウを開くには ウィンドウ ‣ 新しいウィンドウ です。このウィンドウをマルチモニター用にほかのモニタにドラッグできます。

下の画像は Krita でのマルチウィンドウの例です。

../../_images/Multi-window.png

Krita のキャンバス

Krita で最初に新しいドキュメントを作ったら最初に見るものは白い長方形のエリアです。これはキャンバスと呼ばれます。下の画像にある通りです。赤で囲った範囲がキャンバスです。

../../_images/Canvas-krita.png

JPG や PNG などで絵を保存したり印刷する場合は、この範囲内のものだけが考慮されます。範囲を超えたすべては無視されます。Krita はこの範囲絵を超えた情報も格納していて、見えないだけです。このデータは レイヤー に格納されています。

レイヤーと合成

風景を最初に空から描き、遠くのものから目の前に向かって順に作業をするように、コンピュータは指示されたように同じように描写をします。つまり、もし同じ場所に四角を描いた後に丸を描くように指示されたら、丸はいつも最後に描かれます。これは 描画順 と呼ばれます。

レイヤーの重ねは絵の要素を分け、描画される順番を描いた順番から変えられるようになり他のすべてのエフェクトを適用し、重ね順に従い合成する手段になります。これを 合成 といいます。

これによって上に線を残したまま色を塗ったり、山の手前に木を持ってきたり、それぞれを互いに影響させることなく編集することができます。

Krita has many layer-types, each layer type is unique and has its own use case:

Paint Layers

これらはラスターレイヤーで、Krita で一番標準的で既定のレイヤータイプです。ここに絵を描いていきます。

Vector Layers

これはベクターグラフィックを描くレイヤータイプです。典型的にベクターはラスターグラフィックより簡素で不鮮明にならずに変形させるメリットがあります。

Group Layers

これはドラッグ&ドロップで複数のレイヤーをグループにし、管理、移動マスクの適用や他の処理を同時に行うことができます。

Clone Layers

これは製作中に選択したレイヤーのコピーです。元の方に変更を加えると自動でこちらも更新されます。

File Layers

These refer to an existing image outside Krita and update as soon as the outside image updates. Useful for logos and emblems that change a lot.

Fill Layers

色やパターンなど、Krita が簡単にできるもので埋めたレイヤーです。

Filter Layer

これらのレイヤーは下にあるすべてのレイヤーからなる画像に影響するフィルタを適用することができます。

ツール からレイヤーの中を操作することができます。

ツール

ツールは画像のデータを操作する助けになります。一番一般的なのはもちろん、フリーハンドブラシで Krita を開いたときの既定になっています。おおよそ5種類のツールが Krita にはあります:

ペイントツール

ペイントレイヤーに描くためのツールです。長方形や円、直線といった形を表現する、手で描かれた線です。形を作ったりエフェクトを描くためにブラシエンジンによって使われます。

ベクターツール

ツールの上の列にあって、ベクターを編集するために使われます。面白いことにフリーハンドブラシツール以外のすべてのツールがベクターレイヤーに描くのに対応しています。普通のレイヤーにペイントツールを使った場合と違い、枠線にブラシプリセットは使用されません。

選択ツール

選択は作業中のレイヤーの特定部分を他の部分に影響させることなく編集することができます。選択ツールは選択部分に対して描いたり調整できます。これは現実世界の絵で言うマスキング液を使うようなものですが、マスキング液やテープはしばしば乱雑で繊細で、選択ははるかに簡単に使えるものです。

ガイドツール

グリッドや補助線のようなツールです。

変形ツール

キャンバス上のオブジェクトやレイヤーを変形するツールです。

すべてのツールはツールボックスから見つけることができ、それぞれのツール個別の情報はマニュアルの tools で見つけられます。

ブラシエンジン

ブラシエンジンは、上でも述べた通り、線やタブレット情報にエフェクトを追加し描画します。

エンジンとは Krita 開発者が使う複雑なやり取りを行うプログラムのまとまりを意味する語で、中核はまさに機能的であらゆる設定変更が可能です。簡潔に言うと、車のエンジンが車を動かすように、エンジンのタイプやセッティングが車の使い方に影響し、ブラシエンジンが模様や感触に影響し、違うブラシエンジンは違う結果になるということです。

Krita には 多くの異なるブラシエンジンが存在し、すべてが違う効果を持っています。

../../_images/Krita_example_differentbrushengines.png

左: ピクセルブラシ、中央: 色ぼかしブラシ、右: スケッチブラシ。

例えば、ピクセルブラシエンジンは簡素で基本的な作業のほとんどをこなせますが、もし多く塗る場合、色ぼかしブラシエンジンの方が有用でしょう。ピクセルブラシより遅いといっても、色の混ぜ合わせは色の調製混合を必要とする作業を効率的にしてくれます。

もしそれとは全く違うものが欲しければ、スケッチブラシエンジンは乱雑な線を作り出すのにもってこいで、形ブラシエンジンは平らを素早く作れます。Krita のブラシエンジンの中にもクールな効果がたくさんあり、全部使ってみて、それぞれの章も確認してみてください。

エフェクトはブラシ設定のドロップダウンメニューから設定でき、F5 キーからでもすぐにアクセスできます。設定はプリセット内に保存でき、F6 キーかブラシプリセットドッカーからすぐにアクセスできます。

ブラシは色を描写しますが、コンピュータはどのように色を理解するのでしょうか?

人間は数百万色を見ることができ、それは表面に吸収された分を除く、反射された電磁波(光)の組み合わせです。

../../_images/Krita_basics_primaries.png

左は減法混色 CMY、右は加法混色 RGB です。印刷前にこの違いを考慮して色変換します。

伝統的に絵を描くとき、出したい色のために光を吸収する絵の具を使用しますが、絵の具を組み合わせるたびに光が吸収されていき、汚い黒のようになってしまいます。これが現実の塗りのことを 減法混色 と呼ぶゆえんで、絵の具を混ぜ合わせるほど光を減じていきます。これにより、伝統的な塗りでは、最も効率的な色には3つあり: シアンブルーとマゼンタレッドとイエロー(CMY)です。

コンピュータも3原色を使用しそれぞれの量を特定しながら色を保存していきます。しかし、コンピュータの画面は自ら光を放っています。つまりより明るくなって 加法混色 する必要があり、色を合わせれば合わせるほど白になっていきます。これによりコンピュータで使われる最も効率的な3つの原色は、赤、緑、青(RGB)です。

Per pixel, a computer then stores the value of each of these primaries, with the maximum depending on the bit-depth. These are called the components or channels depending on whom you talk to.

../../_images/Krita_basic_channel_rose.png

これは赤いバラ画像の赤チャンネルです。見るように花びらが白くなってきて、この部分が完全な赤であることを示しています。葉はより暗く、赤が足りないことを示しており、ご想像のとおり緑色であるためです。

コンピュータが既定で RGB を使うにも関わらず、CMYK(減法混色)や、LAB のような知覚モデルにも変換することができます。これらすべてはそれぞれの色の関係をどのように示すかの違いであり、たいていは3つのチャンネルを持っています。この例外はグレースケールで、コンピュータはどれだけ色が白いかだけを記録すればよいためです。グレースケールがメモリをより効率的に利用する理由でもあります。

実際、それぞれのチャンネルを分けて見ると、グレースケール画像のように見え、代わりに白がどれだけ赤であるかを表しており、緑や青も同様です。

Krita はとても複雑な色管理システムを持っており、ここ で詳しい情報が読めます。

透過

赤や緑、青と同じようにコンピュータはピクセルがどれだけ透明化も記録することができます。これは先にも述べた通り 合成 するのに重要です。結局、透過がなければレイヤーをいくつも持つ意味はありません。

透過は色と同じ方法で記録され、つまり一つのチャンネルでもあるということです。このチャンネルのことを アルファチャンネル や単に アルファ と呼びます。この呼び方の背景にはプログラミングの世界で'α'文字がそれを意味したことに由来します。

古いプログラムでは必ず既定で透過が使えるわけではありません。Krita は対照的で、透過情報のない画像は理解できず、画像に必ず透過チャンネルを追加します。特定ピクセルがすべてのレイヤーで完全に透明であれば、Krita は上のバラの画像のように代わりにチェッカーボード柄を表示します。

合成モード

Because colors are stored as numbers you can do math with them. We call this Blending Modes or Compositing Modes.

合成モードはレイヤーごとにでもブラシストロークごとにでも適用でき、それゆえにまたレイヤー合成の一部でもあります。

乗算

よく使われる合成モードの例は 乗算 で掛け算をすることにより暗い色になります。これは減法混色を擬似的に再現でき、絵で使われる陰影をより簡単に作り出すことができます。

加算

もう一つよく使われるのは 加算 で、レイヤー片方の成分をもう一つに加算し、輝くような効果に最適です。

消しゴム

消しゴム も Krita の合成モードです。消しゴムツールはありませんが、E キーで素早くブラシを消しゴムに切り替えることができます。またレイヤーにも使用できます。他の合成モードと違い、これはアルファチャンネルにのみ影響し、より透明にすることができます。

通常

通常 合成モードは一番上の色がどれだけ透明かにより、色の平均をとるだけです。

Krita には76の合成モードがあり、それぞれが少しずつ違ったことをします。より詳しく学ぶには 合成モード へ行ってください。

チャンネルはグレースケール画像として見えるため、グレースケール画像をチャンネルに変換することができます。例えば、グレイスケール画像を透過として使うことができます。これらを マスク と呼びます。

マスク

マスクはレイヤーに適用される効果の一つで、たいていはグレースケール画像によって行われます。

最も使われるタイプは Transparency Masks で、グレースケール画像を使って透過を決めることができ、黒ければすべて透明に、白ならピクセルを完全に不透明にします。

どのブラシでもマスクを描いたり、または通常のペイントレイヤーをマスクに変換したりできます。マスクの大きなメリットは下にあるピクセルに手を加えることなく透明にできることです。さらにマスクを使って一度にたくさんのレイヤーを隠したり表示できます!

例えば、ここに白いお化けの少女がいます:

../../_images/Krita_ghostlady_1.png

しかし彼女が本当にお化けの少女なのかただただ白いだけなのかよくわかりません。もし彼女が浮いているように見えればと思うでしょう。そこでレイヤーを右クリックして透過マスクを追加します。それから、そのマスクを選択し黒を下にするように黒白のグラデーションを描きます。

../../_images/Krita_ghostlady_2.png

黒がどこであれ、少女が透明になり、本物のお化けになりました!

マスクという名前はマスク液やマスキングテープから来ています。選択とマスク液の比較をしたのを覚えているでしょう。選択も内部的にはグレースケール画像として記録され、マスクのようなローカル選択として保存したり、透過マスクに変換することができます。

フィルタ

We mentioned earlier that you can do math with colors. But you can also do math with pixels, or groups of pixels or whole layers. In fact, you can make Krita do all sorts of little operations on layers. We call these operations Filters.

そのような作業の例:

脱色

すべてのピクセルをグレーにします。

ブラー

近隣のピクセルで平均を取り、コントラストのシャープさを失わせ画像全体をぼかします。

シャープ化

既にあるピクセル間の差をさらに高めます。

色をアルファに

選んだ色のすべてを透明にするよく使われるフィルタです。

../../_images/Krita_basic_filter_brush.png

それぞれのパーツに異なるフィルタブラシを使った画像

Krita は他にも多くのフィルタが利用できます: それらについては ここ を読んでください。

フィルタブラシエンジン

多くがピクセルごとに適用するのに対し、Krita はフィルタを フィルタブラシエンジン の一部として使うことができます。

ほとんどの画像編集ソフトでは、これらは分けたツールになっていますが、Krita はブラシエンジンとして持っているため通常よりも幅広いカスタマイズが可能になっています。

つまりピクセルの色を抜くブラシや、色相を変えるブラシを作ることができます。

フィルタレイヤー、フィルタマスクとレイヤースタイル

Krita はまたフィルタを Filter LayerFilter Masks 経由でレイヤーの中に収めることができます。フィルタレイヤーは同じ階層内にある下のすべてのレイヤーに適用されます。フィルタレイヤーの透過と透過マスクはレイヤーのどこに適用されるかに影響します。

一方マスクはグレースケール画像により単一のレイヤーにのみ影響します。また透過マスクのようにグループになっているレイヤーすべてに影響します。

We can use these filters to make our ghost lady look even more ethereal, by selecting the ghost lady's layer, and then creating a clone layer. We then right-click and add a filter mask and use Gaussian blur set to 10 or so pixels. The clone layer is then put behind the original layer, and set to the blending mode 'Color Dodge', giving her a definite spooky glow. You can keep on painting on the original layer and everything will get updated automatically!

../../_images/Krita_ghostlady_3.png

Layer Effects or Layer Styles are filter masks popularized by Photoshop's that are a little faster than regular masks, but not as versatile. They are available by right-clicking a layer and selecting 'layer style'.

変形

変形 はフィルタのようですが、画像のピクセルに対して行います。通常の画像や、レイヤートップメニューにあるレイヤーレベルの変形ツールがあり、画像の拡大縮小、反転や回転をすることができます。

またキャンバスサイズにのみ影響する Crop Tool や、指定のレイヤーを動かす Move Tool もあります。しかし、より詳しい制御が必要であれば Krita には Transform Tool があります。

../../_images/Krita_transforms_free.png

このツールでキャンバス上で回転や拡大縮小、遠近を出すこともできます。またさらに格子点、ケージやゆがみなどの応用的な変形ツールもあり、任意の天を選択して変形することも変形ブラシのように扱うこともできます。

変形ブラシエンジン

フィルタブラシエンジンのように、Krita には形状ブラシエンジンもあり、ブラシを使って変形することができます。変形ツールのゆがみモードよりもはるかに早いものですが、品質を引き換えにしています。

../../_images/Krita_transforms_deformvsliquefy.png

ゆがみを使用してリンゴを梨にしたもの(左)と形状ブラシを使ったもの(右)。

また、形状ブラシは非破壊のマスクとして使うことはできません。

Transformation Masks

フィルタのように、変形もレイヤーの重なりの中で非破壊で適用できます。しかしフィルタや透過マスクと違うのは、変形マスクはグレースケール画像によることは技術的な理由でできません。変形マスクで複製やファイルレイヤーの形を変えることはできます。

Animation with Krita

../../_images/Introduction_to_animation_walkcycle_02.gif

バージョン3.0以降、Krita はラスターアニメーションをサポートしました。タイムライン、アニメーションと onionskin ドッカーを使え、さらにラスターアニメーションに使えるバラエティに富んだ Krita のブラシ、エクスポートすれば映像や GIF にできます。

アシスト、グリッドと基準線

技術的なことばかりで、Krita がお絵描きソフトであることをもうお忘れでしょう。現実で絵を描くように、イラストレーターとして、描くのをより簡単にする道具があるように、Krita にもいろいろなツールを用意しています:

../../_images/Krita_basic_assistants.png

Krita の消失点アシストを使ってみたところ。

Grids and Guides Docker

グリッドを表示したり設定な農家ガイドラインを引けるとても単純明快なツールです。

スナップ

グリッド、ガイド、拡張機能、直交描画、画像の中心やバウンディングボックス、ありとあらゆるものにスナップできます。

お絵描きアシスト

タブレットに直接定規を当てて描くのは難しいため、アシストが同心円、消失点、平行線や他の忘れやすくしかしトリッキーなディテールを描く手助けになります。Krita ではツールオプションからでもそれらにスナップできます。

ガイドは Krita のネイティブ形式に保存され、後からでも簡単に作業に戻れます。

カスタマイズ

これで最後の概念: カスタマイズです。

好みに合わせてドッカーを配置するのに加え、Krita は設定を Workspaces として保存できます。これは右上のボタンにあります。

またツールバーは 設定 ‣ ツールバーの設定を変更... から、ショートカットは 設定 ‣ Krita の設定を変更... ‣ ショートカット設定 ‣ Krita の設定を変更... ‣ キャンバス入力の設定 のどちらからでも設定できます。