画像を扱う

コンピュータはファイルを使って動きお絵かきソフトとして、Krita は生成編集するファイルのタイプとして画像を扱います。

画像には何が含まれているの?

テキストドキュメントであればもちろん、正しい順番に並んだ文字情報が含まれており、コンピュータはまとまった文章として読み込みます。

ラスターデータ

This is the main data on the paint layers you make. So these are the strokes with the paint brush and look pixelated up close. A multi-layer file will contain several of such layers, that get overlaid on top of each other so make the final image.

単一レイヤーのファイルはたいていラスターデータのみが含みます。

ベクターデータ

コンピュータにどの場所のピクセルを描くかに数学的手法を使います。拡大するのに座標を4倍にする指示をすれば良いだけなので、拡大縮小がとてもしやすいです。このベクターデーターが編集しやすく軽いのに対し、CPU により負担がかかる面もあります。

作業データ

フィルタレイヤーのような、Krita にレイヤーの色を変える指示をするものだけでなく、透過マスク、グループレイヤーと変形マスクはマルチレイヤーファイルに保存されます。これらを読み込めるかどうかは最初にファイルが作られたソフトウェアに依存します。つまり Krita は PSD からグループ、透過マスクとレイヤーエフェクトの読み込みと保存に対応していますが、変形マスクはどちらもできません。

メタデータ

メタデータは制作日、作者、説明や DPI といった情報のことです。

画像サイズ

この画像サイズはキャンバスの解像度と寸法のことです。画像サイズは Krita ドキュメントのファイルサイズに直接影響します。記録するべきピクセル数が多くなればなるほど、色のビット深度が高くなるほど、ファイルは重くなります。

DPI/PPI

DPI stands for Dots per Inch, PPI stands for Pixels per Inch. In printing industry, suppose if your printer prints at 300 DPI. It means it is actually putting 300 dots of colors in an area equal to an Inch. This means the number of pixels your artwork has in a relative area of an inch.

DPI is the concern of the printer, and artists while creating artwork should keep PPI in mind. According to the PPI you have set, the printers can decide how large your image should be on a piece of paper.

いくつかの標準:

72 PPI

This is the default PPI of monitors as assumed by all programs. It is not fully correct, as most monitors these days have 125 PPI or even 300 PPI for the retina devices. Nonetheless, when making an image for computer consumption, this is the default.

120 PPI

低品質ポスターの標準としてしばしば使われます。

300 PPI

高品質印刷に使うにはこれを最低にすべきでしょう。

600 PPI

この品質は漫画の線画に使われます。

色深度

色深度の話は カラーマネジメントページ に行きました。理解しておく必要があるのは、Krita は画像の色空間とレイヤーの色空間があり、後者は正しく使えばメモリを節約できます。例えば、線画レイヤーをグレースケールにすればメモリコストを半分にできます。

画像の色空間 vs レイヤーの色空間 vs 変換

画像の色空間とレイヤーの色空間に違いがあることにより、画像の色空間だけを 画像 ‣ プロパティ... からレイヤーの方をそのままにして変更することができます。しかしもし全レイヤーも含めてファイルの色空間を変更したい場合は 画像 ‣ 画像の色空間を変換... に行けばレイヤーの色空間もすべて変換されます。

制作者と説明

../_images/document_information_screen.png

Krita は画像を作った人を画像のメタデータに自動的に保存します。作成と更新した時刻とデータのようなデータと一緒に、Krita はまたドキュメント情報ダイアログに編集した時刻を表示し、プロのイラストレーター、スピードペイントで請求のためにアートに作業した時間を記録する必要がある場合には便利です。±60秒の精度で、しばらく何もしていないことを検出します。ドキュメント情報ダイアログと、もちろん .kra ファイルを ZIP 展開してそこにあるメタデータを編集することで空にできます。

これらは ファイル ‣ ドキュメント情報 から、制作者情報は 設定 ‣ Krita の設定を変更... ‣ 作者 から編集することができます。プロファイルは 設定 ‣ アクティブな作者プロファイル から切り替えることができます。

キャンバス背景色を設定する

キャンバスの背景色を 画像 ‣ 画像の背景色と透過度... メニューから設定することができます。ここから背景色を不透明にして色を変えます。また透過の代わりに背景色を強制する特定のファイル形式にも便利です。PNG と JPG で透過をエクスポートしたくない場合はこの色を既定として透過部分を埋めます。

If you come in from a program like Paint Tool SAI, then using this option, or using As canvas color radio button at Background: section in the new file options, will allow you to work in a slightly more comfortable environment, where transparency isn't depicted with checkered boxes.

基本的な変形

画像メニューにはいくつかの基本的な変形が利用できます。

Shear Image...

画像とレイヤー全体を斜めにします。

回転

レイヤーと画像全体を回転させるサブメニューを表示します。

水平/垂直反転

レイヤーと画像全体を反転します。

また他にもオプションがあります...

キャンバスのクロップとリサイズ

画像は クロップツール でクロップし、余分なスペースを切り落として構図を良くする事ができます。

トリミング

画像 ‣ 現在のレイヤーに合わせてトリミング を使うことで、Krita は選択されたレイヤーの寸法に画像をリサイズします。レイヤーに大きすぎる画像を張り付けてしまいキャンバスをこのレイヤーサイズにリサイズしたいときに有用です。

Image ‣ Trim to Selection is a faster cousin to the crop tool. This helps us to resize the canvas to the dimension of any active selection. This is especially useful with right-clicking the layer on the layer stack and choosing Select Opaque. Image ‣ Trim to Selection will then crop the canvas to the selection bounding box.

画像 ‣ 画像のサイズにトリミング はレイヤー用で、全レイヤーを画像のサイズにトリミングし、見えない部分のデータを消すことでファイルを軽くします。

キャンバスのリサイズ

画像 ‣ キャンバスの大きさを変える...`(または :kbd:`Ctrl + Alt + C ショートカット)からキャンバスのリサイズもできます。ダイアログは下に示すとおりです。

../_images/Resize_Canvas.png

この中の、比率を保つ チェックボックスは高さと幅が変更されるとそれぞれが比率を保つようになります。オフセットは現在の画像のどのキャンバススペースに追加されるかを示しています。基本的に現在の画像がどこに行くかを決めます(左ボタンを押せば中心の左側に行き、新しいキャンバススペースが画像の右側に追加されます)。

絵を描く時の必要に駆られてキャンバスをリサイズするもう一つの方法はキャンバスの終わりからさらにスクロールすると、矢印の付いた帯が現れます。ここをクリックすればその方向にキャンバスが拡張されます。矢印は下の例で赤く示したように表示されます:

../_images/Infinite-canvas.png

画像をリサイズする

Scale Image to New Size... allows you to resize the whole image. Also, importantly, this is where you can change the resolution or upres your image. So for instance, if you were initially working at 72 PPI to block in large shapes and colors, images, etc... And now you want to really get in and do some detail work at 300 or 400 PPI this is where you would make the change.

チェーンマークがあった他のすべてのダイアログと同様に、チェーンがつながっていればアスペクト比は維持されます。チェーンを切るには、つながっているところをクリックすれば二つは切り離されます。

../_images/Scale_Image_to_New_Size.png

画像を分ける

../_images/Separate_Image.png

画像を異なる部品やチェンネルに分けられる強力な画像編集機能です。

これは印刷やゲームテクスチャの編集に関わる人にとって有用です。組み合わせる機能はなく、できることは、例えば色の付いた出力があれば二つのチャンネルを加算 合成モード にすることです。

RGB 空間のグレースケール画像では、赤複製、緑複製、青複製合成モードを使い、赤を赤チャンネル用画像に割り当てるといった使い方ができます。

保存、エクスポートとファイルを開く

Krita がファイルを作成したり開くと、ファイルをメモリに複製し、編集します。これはコンピュータの仕組みの一部です: ファイルのコピーを RAM に作ります。それゆえに保存するときは、Krita はそのコピーを既にあるファイルの上にコピーします。保存するときに使える小技がいくつかあります。

保存

Krita は現在の画像をメモリからハードドライブ上の決められた場所に保存します。もし一度も保存されていない画像なら、Krita はどこに保存するか尋ねます。

名前を付けて保存...

違う名前で保存することで現在のファイルのコピーを作成します。Krita は新しく作られたファイルの方をアクティブなドキュメントとして切り替えます。

開く...

保存されたファイルを開きます。よくあるやつです。

エクスポート...

アクティブに開くことなくファイルを新しい場所に保存します。レイヤーのあるファイルで作業をしていて、特定の場所にまとめたバージョンを保存する必要がある場合に便利です。

既存のドキュメントを無題のドキュメントとして開く...

これはちょっと変わり者で、ファイルを開きますが保存する場所は忘れ、'保存'を押すとどこに保存するのか尋ねます。他のプログラムでは'インポート'とも呼ばれます。

現在の画像からコピーを作成

現在の画像のコピーを作成します。既存のドキュメントを無題のドキュメントとして開く... に似ていますが、既に開いてあるファイルで行います。

差分バージョンを保存

Saves the current image as filename_XXX.kra and switches the current document to it.

差分バックアップを保存

Copies and renames the last saved version of your file to a backup file and saves your document under the original name.

注釈

Since Krita's file format is compressed data file, in case of a corrupt or broken file you can open it with archive managers and extract the contents of the layers. This will help you to recover as much as possible data from the file. On Windows, you will need to rename it to filename.zip to open it.