基础概念

本页面是专门为刚刚接触数字绘画的新手们准备的。在这里你不但能学会 Krita 的基本操作,还能够学会数字绘画的各种必备知识。

不管是入门 Krita 还是入门数字绘画本身,涉及的知识点都非常多。为了不让本页内容显得过于冗长,我们尽可能以简明的方式向读者介绍最重要的方面,而不会事无巨细地展开讲述每个知识点的方方面面。

栅格图像和矢量图形

Krita 是一款栅格图像处理软件,但它也具备一定的矢量图形编辑功能。如果你是数字绘画初学者,那么请先了解一下栅格和 矢量 的概念。

在数字影像技术中,像素 (pixel,图像元素 Picture Element 的缩写) 是组成图像的最基础的元素。把数字图像放大后你会发现它呈网格状,每个网格单独呈现一种颜色,这些网格中的每一格就是一个像素。由像素构成的图像就是栅格图像。在 Krita 里面,当你使用一个大小为 1 像素的黑色笔刷在白色画布上作画时,你实际上是在把笔刷下面的那个像素的颜色从白改成了黑。如果把某个笔画放大观察,你可以看见许多颜色小方块,它们就是像素:

../../_images/Pixels-brushstroke.png

和栅格图像不同,矢量图形是通过数学方式记录形状的,它们并不依赖像素。如果你在 Krita 的 矢量图层 上用矩形工具绘制了一个四边形,该工具实际上只创建了四个节点,每个节点都有一组 X 轴和 Y 轴坐标,四个节点之间以路径相连,路径被按照指定的参数描边后呈现出实际形状。当你移动了这些节点时,计算机会重新算出连线的路径并按照描边参数重新绘制形状。因此,无论你如何对矢量图形进行变形,它们呈现的图像品质会始终如一,不会劣化。在 Krita 里,矢量图层之外的内容都是栅格图像。

图像、视图和窗口

绘画软件的工作空间由三大部分组成。

图像

在工作空间中最重要的部分便是 图像

你可以在 文件 菜单中新建图像或者打开已有图像。Krita 会自动把图像复制成一份临时的工作副本打开,所有编辑工作都在此工作副本中进行,直到你保存时才会写回存储器覆盖已有文件。你可以在 Krita 里把图像另存为新文件,或者保存增量副本。

一个图像文件包含多种数据,如图层、图层和图像的色彩空间、画布尺寸、元数据如创建者、创建日期、DPI 等信息。Krita 可以同时打开多个图像,你可以通过画布视图的标签或者 窗口 菜单进行切换。

因为在 Krita 窗口中显示的图像只是硬盘中已有文件的工作副本,所以我们可以使用下列几种不同的方式打开和保存文件:

新建

创建一个新的图像。当你点击 保存 时,该图像会被保存成硬盘上的一个新文件。

打开…

在 Krita 内部生成已有图像文件的一个工作副本。当你点击 保存 时,此工作副本将覆盖原始图像文件。

打开为无标题图像…

类似于 打开,但点击 保存 时将要求你指定一个新的保存位置,把它保存成一个不同的文件。这与其他软件的 导入 类似。

新建图像 - 复制当前图像

类似于 打开为无标题图像,但这个功能是把当前显示的图像另存一个副本。

保存增量版本

让你可以快速保存当前图像的一个快照,快照的文件名会自动附加一串版本数字作为后缀。

这些不同的文件打开和保存的方式可以提高工作效率。你可以在不同版本的文件之间快速切换,也可以在进行大幅修改前快速备份文件。Krita 还具备自动文件备份系统,可以按时自动保存文件,自动保存备份,崩溃后恢复文件等功能。你可以在常规设置中配置相关选项。

你必须在 视图 里面观察打开的图像。

视图

视图是一个在 Krita 界面中显示已打开图像的子窗口。你可以在 Krita 里面打开多个文件到不同的视图,也可以为同一个文件创建多个视图。每个视图都有独立的缩放、旋转、镜像和色彩管理等显示参数,更改这些参数并不会修改图像本身的数据。通过操作视图的显示方式,如按 M 镜像显示画布,画师可以快速检查作品的失误。

如果你在绘制某些角度刁钻的曲线时觉得不顺手,你可以把视图旋转之后再进行绘制。你也可以在需要刻画细节时放大视图,需要大笔勾勒时缩小视图。

../../_images/Krita_multiple_views.png

Krita 可以显示同一个图像的多个视图

如果需要为同一个图像显示多个视图,点击菜单栏的 窗口 ‣ 新建视图 ‣ 图像名称 。你可以在 窗口 菜单切换视图,也可以按 Ctrl + Tab 来进行切换。如果需要并排显示多个视图,请打开 设置 对话框,在 窗口 ‣ 多文档模式 下拉菜单选中“子窗口”。

工具面板

工具面板是 Krita 界面内部的一种子窗口。每种工具面板都具备特定的功能,如拾色器、图层组、工具选项等。你可以通过拖拽和吸附等方式自由安排工具面板的位置和组合。详见 视图控制 页面。

../../_images/Dockers.png

上图展示了 Krita 的部分工具面板。

所有的视图和工具面板都被显示在 窗口 内部。

窗口

如果你以前使用过计算机,你应该对窗口很熟悉:它们是显示各种程序的容器。

如需同时打开多个 Krita 窗口,可前往菜单栏的 窗口 ‣ 新窗口 。如果是多屏显示的环境,每个窗口可被拖动到不同的显示器上。

下图展示了 Krita 的多窗口状态。

../../_images/Multi-window.png

画布

在 Krita 里新建一个文档后,你会看到一个矩形的白色区域。这个区域就叫做画布。你可以在下图的红框中确认它的位置。

../../_images/Canvas-krita.png

当你把图像保存成 JPG、PNG 等格式,抑或是将作品打印出来时,只有位于画布里面的部分才会被保存/打印,在画布外面的信息将被忽略。在关闭图像前,Krita 依然会在内存中保存画布外面的信息,尽管你并不能看到它们。如需保存画布外面的信息到文件,必须使用 KRA 格式。图像信息被保存在 图层 中,一张图像可以有多个图层。

图层和合成

如果你把一张圆形的纸片叠放在一张方形的纸片之上,圆形的纸片会遮挡方形的纸片。计算机在处理这种多层堆叠的图像时会先绘制下面一层,然后再绘制上面一层,这样下面一层就会被上面一层遮盖。这叫做 绘制顺序

在数字绘画中,你可以通过图层组把不同的元素分开在不同的图层绘制。各个图层的内容保持独立,你可以随时更改它们的内容和前后顺序,最终合并输出成成品。这叫做 合成

你可以通过图层把线稿置于底色之上,或者把树木放在远山前面,在编辑时图层之间不会互相影响。

Krita 的图层有多种类型,每种图层都有独特的用途:

颜料图层

这种图层就是栅格图层。这是 Krita 最常用的一种图层,手绘笔刷工具等大多数工具都是在这种图层上进行绘制的。

矢量图层

这种图层专门用于绘制矢量图形。矢量图形一般比栅格图像更简单,在变形后也不会变模糊。

分组图层

你可以把其他图层拖放到这种图层里成为一组,然后便可以对整组图层进行组织、移动、应用蒙版以及其他操作。

克隆图层

这种图层是另一个图层的实时克隆,你创建它们时选中的图层就是它们的母本,所有对母本图层的修改都会立即反映到它的克隆图层上面。

文件图层

这种图层会调用一个外部图像文件作为其内容。适用于类似徽标等需要频繁独立于图像本身更新的视觉元素。

填充图层

这种图层用来填充 Krita 能够自行生成的内容,如颜色或图案等。

滤镜图层

这种图层可以用来应用部分滤镜,它的滤镜效果会影响位于它下面的所有图层。

你可以用 工具 来操作图层里面的内容。

工具

你可以使用工具来对图像的数据进行操作。最常用的工具当然是手绘笔刷,Krita 也会在启动之后默认选中它。Krita 的工具可以被笼统地分为 5 大类:

绘画工具

这组工具用于在颜料图层上进行绘画。它们既可以按照矩形、圆形和直线等形状进行描绘,也可以按手绘的路径进行描绘。它们还可以通过笔刷引擎来绘制出不同的形状和效果。

矢量工具

这组工具位于工具箱的最顶端,用来编辑矢量形状。除了手绘笔刷工具外的所有工具都能在矢量图层上绘制形状。在颜料图层中的矢量形状可以使用笔刷预设来进行描边,但在矢量图层中的矢量形状则不行。

选区工具

选区工具可以圈选一定的区域,限制其他工具只能在这个区域内进行操作。选区本身也可以作为透明度蒙版进行编辑,与传统绘画使用的留白液异曲同工。

导线工具

包括网格和辅助尺等。

变形工具

这组工具可以对选区内容、形状甚至整个图层进行变形操作。

所有这些工具都可以在工具箱中找到。它们的详细功能和操作可以在参考手册的 工具 分类中查阅。

笔刷引擎

笔刷引擎通过读取数位板的传感器数据,如光标的移动轨迹、移动速度、笔身角度和朝向、压力变化等,配合不同的算法和参数,绘制出具有各种风格的笔画。

“引擎”是我们用来描述一套具有复杂功能的程序代码的行话。Krita 的笔刷引擎和汽车的引擎一样具有许多可供调整的环节,每个环节都会影响到其他环节的工作表现。正如汽车引擎中每个零件的调教会影响到汽车的性能,笔刷引擎的各个选项的调整也会使绘制的笔画呈现出不同的效果。

Krita 内建了 种类繁多的笔刷引擎,它们的工作原理各不相同,效果各具特色,每一种引擎都有其独特的用途。

../../_images/Krita_example_differentbrushengines.png

左图: 像素笔刷引擎; 中图: 颜色涂抹笔刷引擎; 右图: 草图笔刷。

像素笔刷引擎和颜色涂抹笔刷引擎是数字绘画最常用到的两种笔刷引擎。像素引擎的工作原理最为简单,处理速度也最快,采用这种引擎的笔刷预设可以很好地完成绝大多数的基本绘画工作。而颜色涂抹引擎虽然比像素引擎要慢,但它在混合颜色时效率更高。

有些笔刷引擎的工作原理比较独特。草图笔刷引擎可以画出潦草的线条,形状笔刷引擎可以快速铺色。Krita 的笔刷引擎还可以营造许多其他有趣的效果,大胆地去进行尝试吧!

要调整笔刷效果,可以点击工具栏的“笔刷选项”下拉面板,也可以按 F5 直接弹出。你可以把修改过的笔刷选项保存成到预设。按 F6 可以快速访问“笔刷预设” 工具面板。

笔刷可以画出各种颜色,那么计算机又是如何理解色彩的呢?

色彩

人眼可以分辨几百万种颜色,色彩是人类对射入眼睛的光线的感知,而光是一种电磁波。任何物体的表面都会反射、吸收不同波长的电磁波 (光) ,不同波长的光呈现出不同的颜色。

../../_images/Krita_basics_primaries.png

左图:符合减色法原则的 CMY 色彩模型;右图:符合加色法的 RGB 色彩模型。由于两者的差异,图像在打印前都需要进行一次色彩转换。

在传统绘画中我们使用颜料作画。不同的颜料会吸收不同波长的光,从而呈现出它们应有的颜色。但是混合的颜料越多,被吸收的光就越多,颜色也会变得越来越浑浊灰暗,所以我们也把颜料的混合原理叫做 减色法。基于这种原理,在传统颜料中,混色效果最好的三原色都是比较明亮的颜色:青、品红和黄 (CMY)。

计算机同样使用三原色,它通过标注一种颜色所含的三原色的数值来保存颜色。计算机的屏幕是发光体,而不同的色光在混合后会变得更加明亮,直到变为白色,所以这种混色原理又叫做 色光加色法。在计算机的使用情景里,混色效果最好的三原色是红、绿、蓝 (RGB)。

计算机以像素为单位保存颜色的三原色数值。在不同的色彩模型里面,可以显示的颜色种类与颜色的 分量 或者 通道 的位深度有关。

../../_images/Krita_basic_channel_rose.png

上图是一张红玫瑰的图像中的红色通道。我们可以看到花瓣是浅白色的,这意味着那些区域的红色含量高。茎叶的颜色很暗,意味着红色的含量少——因为它们是绿色的。

计算机默认使用 RGB 色彩模型,但它们也可以把颜色转换成减色法的 CMYK 模型,或者可感知的模型,如 LAB 模型。无论是哪种模型,本质上都是在描述颜色的相互关系,它们通常都会包含三个分量。灰阶图像是个例外,在这个模型里计算机只需保存一种颜色有多白,所以灰阶图像比较节省内存。

如果你把每个通道分离出来单独观察,会发现它们看起来像是一张灰阶图像,但它们实际上描述的是画面上的红、绿、蓝有多少。

Krita 内建了一套非常复杂的色彩管理体系,你可以在 此章节 进一步了解。

透明度

和红、绿、蓝一样,计算机也可以保存一个像素的透明程度。透明度对于前面提到过的 图层合成 至关重要,因为要是图层没有透明区域的话,把画面内容分成几个图层又有什么意义呢?

透明度和颜色使用相同的方式进行保存,所以它也有自己的通道。我们通常把这条通道叫做 阿尔法通道 或者简称为 alpha。这是因为希腊字母“α”被用于在编程中表示透明度。为了方便初学者理解,我们在 Krita 中将其翻译为 透明度通道

某些老旧的应用程序会默认创建不带透明度的图像,把背景显示为白色。而 Krita 在任何情况下都会创建带有透明度通道的图像,如果图像本身不含透明度通道,它会自动添加一个。带有透明度通道的图像在被擦除底色后,会显示出棋盘格状的背景。灰色的棋盘格在数字绘画中代表“透明”。

混色模式

因为颜色是以数字形式进行保存的,所以我们可以对它们进行数学计算。计算的方式有很多种,我们把它们统称为 混色模式 或者 合成模式

混色模式可被应用到每个图层或者每一笔画。它是图层合成的重要环节。

相乘

相乘 是一种常用的混色模式。它把两个图层的颜色分量相乘,得到更深的颜色。我们可以用它模拟减色混色法,这样可以更容易地画出阴影。因为某些原因,在 Photoshop 等软件中它常常被翻译为“正片叠底”。

相加

加法 也是一种常见的混色模式,它会把两个图层的颜色分量相加,非常适合用来营造发光特效。

擦除

擦除 是 Krita 的一种混色模式。和其他混色模式不同,它只对透明度通道起效果,让像素变得更加透明。Krita 没有单独的橡皮擦工具,但你可以随时按 E 把当前笔刷切换到擦除模式,我们的橡皮擦笔刷预设也是基于此原理打造的。你也可以把图层设成擦除模式。

正常

正常 混色模式按照上层图层的透明度来决定如何分配两个图层的颜色。

Krita 有 76 种混色模式,每种的效果都不尽相同。想要进一步了解它们的原理和用法,请阅读 混合模式 章节。

因为颜色通道可被视作灰阶图像,所以我们也可以把灰阶图像转换成颜色通道。例如,我们可以把一张灰阶图像用作透明度通道。我们把这种用法叫做 蒙版

蒙版

蒙版图层可以在别的图层上面产生附加效果,它们通常基于一张灰阶图像。

最常用的模板是 透明度蒙版 ,它通过蒙版图像的灰阶信息来确定透明度。黑色为完全透明,白色为完全不透明 (实色)。

你可以使用任意笔刷在蒙版上绘画,也可以把一个正常的颜料图层转换成蒙版。使用蒙版的意义在于你可以在不擦除原图层像素的情况下把它们变为透明。你也可以使用蒙版为整个图层分组施加透明度。

例如,我们打算绘制一只白色的女鬼:

../../_images/Krita_ghostlady_1.png

如果只是画成这种实心的白色,我们不好说她到底是真的鬼还是白得发亮。最好还是要营造出一种半透明的漂浮在空中的感觉。在女鬼的图层单击右键,添加一个透明度蒙版。我们在蒙版上应用一个线性的黑白渐变,黑色一端在画面下方,白色一端在画面上方。

../../_images/Krita_ghostlady_2.png

蒙版上的颜色越黑,人物图层的颜色就越透明,这下就有点女鬼的意思了!

蒙版这个名字最初起源于电影行业,它和前面提到的留白胶作用类似。Krita 的选区和蒙版一样,也是作为灰阶图像被保存在程序内部的。如果你把一个选区保存成本地选区,实际上等于创建了一个蒙版,所以本地选区也可以被转换成透明度蒙版。

滤镜

我们之前已经介绍过如何对颜色进行数学运算。你可以对某个像素、一组像素或者整个图层的像素进行数学运算。Krita 可以对图层进行各种各样的有趣处理。我们把这些处理叫做 滤镜

以下面的滤镜处理为例:

去色

此滤镜会把所有的像素变成灰阶。

模糊

此滤镜会把相邻的像素平均化,对硬边和强烈的反差进行柔化,使得图像整体看起来模糊柔和。

锐化

此滤镜会进一步增加本身反差较大的像素之间的反差。

颜色转为透明度

此滤镜可以把所选的颜色变成透明。

../../_images/Krita_basic_filter_brush.png

这张图像的不同部分被应用了不同的滤镜。

Krita 还带有大量其他的滤镜,参见 滤镜 页面。

滤镜笔刷引擎

因为大多数的滤镜处理均针对像素,所以 Krita 也可以在 滤镜笔刷引擎 里面使用滤镜。

在绝大多数图像处理软件中,滤镜和笔刷都是相互独立的工具。但 Krita 把滤镜也整合在了笔刷引擎里面,你可以用它创作出更多样化的效果。

这意味着你可以制作一个有去色效果的笔刷,或者是一个能改变色相的笔刷。

滤镜图层、滤镜蒙版和图层样式

Krita 还允许你把滤镜应用到图层组上,作为 滤镜图层滤镜蒙版。滤镜图层按照继承关系影响与其关联的图层。在滤镜图层上调整透明度和应用透明度蒙版可以影响它们作用的图层和区域。

滤镜蒙版可以通过一张灰阶图像影响一个图层或者一个分组,这和透明度蒙版类似。

我们可以使用滤镜图层来让刚才的女鬼变得更加鬼模鬼样。在女鬼的图层上点击右键,创建一个克隆图层。在这个克隆图层上点击右键,创建一个滤镜蒙版,选用“高斯模糊”滤镜,把半径设为 10px 左右。我们把克隆图层放在原始图层的下面,然后把混色模式设为“ 颜色减淡 ”。这会营造出一种鬼里鬼气的幽光。做完这一步后,如果你在原始图层上继续修改,效果图层会自动保持同步更新,省事极了!

../../_images/Krita_ghostlady_3.png

图层样式是一种来自 Photoshop's 的滤镜蒙版,它们比一般的蒙版处理速度稍快,但用途不如后者广泛。要使用图层样式,你可以在图层上点击右键,选择“图层样式”。

变形

变形 和滤镜一样,本质上都是对图像的像素进行自动化处理。我们准备了多种变形方式。除了工具箱的几种变形工具外,如果要针对整个图层或者图像进行缩放、翻转和旋转操作,可以在“图层”和“图像”菜单中找到相关选项。

在工具箱里面,Krita 提供了 裁剪工具,它只能用来修改画布大小;移动工具,它只能用来移动一个图层。如果你需要更多控制,Krita 还准备了 变形工具

../../_images/Krita_transforms_free.png

变形工具可以对画布上的对象进行旋转、调整大小、透视变化等操作。它还有一些更高级的变形功能,如绘制控制点后对其进行拖动变形的网面变形和外框变形,还有仿佛是一个变形笔刷一样的液化变形等。

扭曲笔刷引擎

扭曲笔刷引擎 和滤镜笔刷引擎类似,可以让你使用笔刷进行变形操作。扭曲笔刷就像是一个更快速的变形工具液化模式,但生成的图像品质要低许多。

../../_images/Krita_transforms_deformvsliquefy.png

同样是把一个苹果变形为梨形,左图使用了液化变形,右图使用了扭曲笔刷。

还有一点,扭曲笔刷无法在非破坏性蒙版上使用。

变形蒙版

和滤镜一样,变形也可以被作为一种非破坏性操作应用到图层组里。但和滤镜蒙版、透明度蒙版不同的是, 变形蒙版 由于其技术特点,并非基于灰阶图像。你还可以使用变形蒙版来对克隆或文件图层进行变形。

动画制作

../../_images/Introduction_to_animation_walkcycle_02.gif

Krita 自 3.0 版起可以制作基于栅格图像的逐帧动画,配有时间轴、动画和洋葱皮视图等工具面板。你可以运用 Krita 强大的笔刷直接绘制动画,并将它们导出成视频或者 GIF 动画。

辅助尺、网格和导线

尽管 Krita 功能强大复杂,但本质上它还是一个绘画工具。传统的画家有各种工具来为绘画工作提供便利,Krita 也为绘画提供了一系列辅助工具:

../../_images/Krita_basic_assistants.png

Krita 的灭点辅助尺正在工作。

网格与参考线

网格和参考线由一个直观的工具面板来控制,可以精细调整间距、细分、颜色、透明度等相关显示方式。

吸附

你可以把对象或绘画笔迹吸附到各种辅助工具上,如网格、导线、延长线、正交线、图像中心点和外框等处。

绘画辅助尺

在数位板上面使用尺子不太现实,所以 Krita 专门为此准备了一套绘画辅助尺工具。它们可以帮助你随心所欲地绘制同心圆、透视、平行线,无需与复杂的绘画原理打交道。只需在工具选项勾选“吸附到辅助尺”,你就可以把笔迹吸附到这些辅助尺上面进行绘画。

上述工具创建的信息也会被保存到 Krita 的原生文件格式内,这样你在继续之前的工作时就无需费劲地重新调整它们了。

客制化

我们要介绍的最后一个概念是客制化。客制化指的是用户在使用软件时可以根据自己的喜好对软件的界面进行调整。

Krita 给了用户充分的自由度进行客制化。除了按照个人喜好自由安排工具面板外,还可以把自定义配置保存为 工作区。工作空间的管理按钮在窗口的右上角。

要配置工具栏,点击菜单栏的 设置 ‣ 配置工具栏;要配置快捷键,点击菜单栏的 设置 ‣ 配置 Krita ‣ 键盘快捷键设置 ‣ 配置 Krita ‣ 画布输入设置