理解和处理图像

计算机可以处理不同类型的文件,而作为绘画程序,Krita 能够创建和处理图像文件。

图像文件包含的数据

如果你创建了一个文本文档,它里面文字的字母会依照某种顺序进行排列,这样计算机才能把字母读取并显示成连贯的句子。这种排序方式就是该文本文档的格式。每种文件都有自己的格式,图像文件也不例外。Krita 的图像文件包含下列数据:

栅格数据

这里保存了颜料图层的主要数据。你用手绘笔刷工具绘制的笔画和颜色就被存放在这里。栅格图像记录了每一个像素的颜色,图像被放大时会产生马赛克。一个图像可以包含多个图层,它们从上到下依次叠放组成了最终图像。

单层图像文件通常只包含栅格数据。

矢量数据

这里保存的是一些数学运算,计算机通过这些运算决定如何绘制画面,这个特点使得它们具有更好的伸缩性。你只需要告诉该运算把坐标值增大 4 倍,生成的图像就可以跟着放大,而放大后的细节不会有任何损失。矢量数据的体积更小,可编辑性也更好,但代价是消耗更多的 CPU 资源。

操作数据

这里保存了软件在各种图层中进行的操作,例如用来调整其他图层颜色的滤镜图层、透明度蒙版、图层组和变形蒙版等。不同软件的操作数据格式有所差别,Krita 对这些数据的支持情况取决于文件是由哪些软件生成的。例如,Krita 能够加载和保存 PSD 文件的图层组、透明度蒙版和图层样式,但无法加载和保存它的变形蒙版。

元数据

元数据是一组记录了创建日期、作者、描述文字等信息的数据,它也包括了 DPI (每英寸点数) 等文件格式的特有信息。

图像大小

图像大小包括了两个方面:画布的尺寸和分辨率,它们的大小直接影响 Krita 图像文件的体积。需要记录的像素越多,颜色的位深度越高,则生成的文件体积越大。

DPI 与 PPI

DPIDots per Inch (每英寸点数) 的缩写,而 PPIPixels per Inch (每英寸像素) 的缩写。DPI 与打印的精细程度有关,而 PPI 则与打印尺寸有关。在印刷行业里面,如果一台打印机按 300 DPI 进行打印,它在每平方英寸的面积里面可以打印 300 个墨点。为了发挥出这台打印机的真正性能,打印的图像至少要在每平方英寸的面积里提供 300 个像素的信息。

DPI 是打印机的特性决定的,它并不直接影响图像的打印尺寸大小。真正对打印大小起决定作用的是 PPI ,它直接描述了像素和打印尺寸之间的关系。换句话说,一张图像的 PPI 决定了它每个像素被打印在纸张上的大小,而 DPI 反映了一台打印机的打印精细程度。画师在创作时更应关注 PPI

现列出部分 PPI 标准如下:

72 PPI

这是所有程序默认的显示器 PPI。这个数值不一定准确,因为新型显示器普遍已经达到 125 PPI,使用视网膜屏幕的设备甚至可以超过 300 PPI。尽管如此,它依然是制作屏幕显示用图像的默认设置。

120 PPI

这个数值经常被用作低质量海报的标准。

300 PPI

这个数值是高质量印刷的最低限度。

600 PPI

漫画线稿使用的品质。

颜色位深度

我们在 色彩管理 章节对颜色的位深度进行了探讨。Krita 不但可以为图像指定色彩空间,还可以为图层指定色彩空间。我们可以通过巧用图层色彩空间来节省内存。例如,把线稿图层设为灰阶,可将内存的消耗量减半。

图像色彩空间、图层色彩空间、色彩转换

图像和图层的色彩空间是被区别对待的。要修改图像的色彩空间,可到菜单栏的 图像 ‣ 属性 里面进行,但这些选项不会改变图层的颜色。如果需要把图像连同所有图层的色彩空间一起进行转换,可到菜单栏的 图像 ‣ 转换图像色彩空间

作者和描述信息

../_images/document_information_screen.png

Krita 会自动把图像的创建者保存到文件的元数据。Krita 的图像信息对话框除了显示文件的创建、修改日期和时间外,还能显示图像的总编辑时间长度,方便按工时计费。如果你有一段时间没有进行操作,Krita 会及时发现并停止计时,精度为 ±60 秒。你可以在文件信息对话框清除计时信息,也可以在解压缩该 .kra 文件后编辑相关的元数据。

要编辑图像信息,可在菜单栏点击 文件 ‣ 图像信息。要编辑作者信息,可在菜单栏点击 设置 ‣ 配置 Krita ‣ 作者。要切换作者档案,可在菜单栏点击 设置 ‣ 当前作者档案

设置画布背景色

要设置画布的背景色,在菜单栏点击 图像 ‣ 图像背景色与透明度,你可以在这里更改背景色,或者把背景色改为不透明。这对于那些强制使用不透明背景的图像格式有用。如果你不保存透明度,PNG 和 JPG 在导出时会使用此颜色作为背景。

如果你习惯使用 Paint Tool SAI 这样的程序,不希望见到透明度棋盘格背景,你可以调整上述选项,也可以在新建文件对话框的“内容”页面中通过 背景色背景不透明度 选项更改新建图像的默认值。

基本变形

你可以在 图像 菜单中进行一些基本的变形操作。

斜切图像…

此功能可以把图像和所含的全部图层进行斜向扭曲。

旋转

此菜单中的操作可以把图像和所含的全部图层进行旋转。

水平/垂直翻转

此功能可以把图像和所含的全部图层进行翻转。

除此之外我们还有更多的相关选项,下面将继续介绍。

裁剪和调整画布大小

要对图像进行裁剪,可使用裁剪工具。此功能可用于切除多余的空白和改善构图。

修剪

使用菜单栏中 图像 ‣ 裁切至当前图层,Krita 可以把图像的尺寸调整为当前已选中图层的大小。如果你粘贴进来的内容超出了图像的尺寸,你可以使用此功能把图像尺寸扩展至所粘贴图层的大小。

菜单栏的 图像 ‣ 裁切至选区大小 功能是裁剪工具的一种快速替代品,它可以把画布尺寸调整为当前活动选区的大小。其中一种用法是在图层列表上右键单击一个图层,选择 选择不透明区域,然后在菜单栏选择 图像 ‣ 裁切至选区大小,这样即可按照该选区 (也就是所选图层的内容边界) 的水平和垂直大小对图像进行裁剪。

菜单栏的 图像 ‣ 裁切至图像大小 功能可以按照图像尺寸对所有图层进行裁切,去除图像边框之外的不可见区域的内容,减小文件的体积。

调整画布大小

你还可以通过菜单栏的 图像-> 调整画布大小 (或按 Ctrl + Alt + C 组合键) 来对画布的大小进行调整。该对话框显示如下。

../_images/Resize_Canvas.png

保持宽高比 选项可确保图像的宽度和高度和修改之前保持相同的比例。偏移 选项决定了画布四周各个方向的尺寸增减量,也就是控制当前画布相对于修改后画布的位置。点击 锚点 的任意一个方向可以让当前画布与修改后画布沿该边 (角) 对齐。例如,点击左边箭头,则画布在水平方向上的全部大小增减会发生在它的右边。

调整图像大小的另一个办法是把画布视图朝一个方向滚动,直到在那个方向的边框处出现一个箭头按钮。点击它,画布就会朝该方向扩展。示例如下:

../_images/Infinite-canvas.png

缩放图像至新尺寸

缩放图像大小 可对整个图像按比例缩放。如果你需要放大图像尺寸,应使用此功能。例如,你的图像的分辨率原来是 72 PPI,你在这个低分辨率下面规划完了大致的配色和构图,下一步就要刻画细节了,于是你可以在这里把分辨率调高到 300 或者 400 PPI。

和所有显示了锁链按钮的对话框一样,这个对话框的锁链按钮用来锁定图像的宽高比。点击该按钮可以解除锁定,让你可以单独控制宽度和高度的数值。

../_images/Scale_Image_to_New_Size.png

分离图像

../_images/Separate_Image.png

这是一个功能强大的图像处理功能,可以把一张图像的颜色通道分离开来。

此功能对于印刷和处理游戏材质尤为有用。虽然 Krita 没有提供反向合并的功能,但你可以把分离出来的图层设为“相加” 混合模式 来模拟合并后的效果。

对于从 RGB 图像分离得到的各通道灰阶图像,我们可以依次把红、绿、蓝通道的图像的混合模式设为“复制红通道”、“复制绿通道”、“复制蓝通道”。

保存、导出和打开文件

Krita 在创建或者打开一个文件之后,它会把该文件的数据保存一份副本到内存里,以供它编辑时使用。这是计算机的工作原理所决定的:它们要把文件加载到内存里面才能对其进行操作。在保存文件时,Krita 会用内存中的副本覆盖硬盘上的已有文件。图像的打开和保存操作有下面几种:

保存

Krita 会把当前内存中的图像保存到硬盘上的指定位置。如果该文件之前未被保存过,Krita 会询问应该把它保存在什么位置。

另存为…

把当前打开的文件在另一个位置保存为副本。保存结束后 Krita 会切换到该新文件继续编辑。

打开…

打开已有文件。

导出…

把一个文件保存一个副本到新位置,但保存后不切换到导出的文件,而是继续使用当前文件进行编辑。如果你在处理一个多图层文件,需要输出一个平整后的图像与他人分享,这个功能将非常有用。

打开为无标题图像…

这个功能不太好理解,它所做的是打开一个已有文件,但在保存时会询问一个新位置来把结果保存为原始文件的一个副本。在其他程序里此功能叫做“导入”。

从当前图像创建副本

为当前图像制作一个副本。和“打开为无标题图像”类似,但对象换成了当前打开了的文件。

保存增量版本

将当前图像保存为 文件名_XXX.kra ,并以该图像作为当前图像。

保存增量备份

复制上一次保存的图像文件为一个备份副本,然后将当前图像以原始文件名保存。

备注

Krita 的工作文件格式实质上是一个压缩包,万一该文件发生了损坏,你还可以用解压缩软件把它包含的图层等内容解压出来,尽可能恢复更多的数据。在 Windows 环境下,你需要把文件的名称改为 文件名.zip 这样的格式才能双击打开。