기초 개념

이 페이지는 Krita에서 디지털 페인팅을 처음 시작하는 데 필요한 기본적이지만 중요한 개념에 대해 간략하게 소개하는 페이지입니다. 디지털 페인팅을 처음 시작한다면 읽어 보는 것을 추천합니다.

비록 매우 길지만, 이 페이지에서는 Krita의 가장 중요한 기능 중 몇 가지를 간략하게 설명합니다. Krita의 다양한 메뉴와 단추의 기능을 이해하는 데 도움을 줄 것입니다.

래스터와 벡터

Krita는 래스터 기반 프로그램이지만, 벡터 편집 기능 또한 탑재하고 있습니다. 디지털 페인팅 매체를 처음 접하는 경우 먼저 래스터 및 벡터 기반 이미지의 배경을 숙지할 필요가 있습니다.

디지털 이미징에서 픽셀은 가장 기본적이고 작은 단위입니다. 이는 각각 특정한 색을 표시하는 점들을 격자형으로 늘어놓은 것으로, 래스터 편집은 이 픽셀을 조작하고 편집합니다. 예를 들어 검정색으로 칠해진 1픽셀의 브러시로 Krita의 흰 캔버스를 칠한다면, 실제로는 브러시 아래에 있는 픽셀의 색을 흰색에서 검은색으로 바꾸고 있는 것입니다. 확대해서 브러시 스트로크를 보면 작은 사각형들이 많이 보이는데, 이 사각형이 픽셀입니다:

../../_images/Pixels-brushstroke.png

래스터 이미지와 다르게 백터 그래픽 이미지는 픽셀과 독립된 수식을 기반으로 합니다. 예를 들어 Krita의 벡터 레이어에 직사각형을 그린다면, 실제로는 ‘x’ 축과 ‘y’ 축의 특정 좌표에 위치한 노드라고 불리는 지점을 통과하는 경로를 그립니다. 이러한 점의 크기를 조정하거나 이동할 때 시스템이 경로를 계산하고 다시 그리며, 이를 통해 형성된 모양을 사용자에게 표시합니다. 따라서 벡터 이미지는 품질 손실 없이 이미지의 크기를 원하는 수준으로 조정할 수 있습니다. Krita에서는 벡터 레이어에 있지 않은 모든 것은 전부 래스터 기반에 해당됩니다.

이미지, 보기, 창

그림을 그리는 프로그램에는 작업 공간을 구성하는 세 가지 주요 요소가 있습니다.

이미지

가장 중요한 것은 이미지입니다.

이 이미지는 파일 대화 상자를 통해 열거나 만들 수 있는 이미지의 복사본입니다. Krita는 파일 메뉴를 통해 파일을 복사본으로 열거나, 새 파일로 저장하거나, 증분된 복사본을 만들 수 있도록 합니다.

이미지에는 레이어, 이미지와 레이어의 색 공간, 캔버스 크기 등 데이터와 만든 사람, 만든 날짜, DPI 등 메타데이터가 포함되어 있습니다. Krita는 한 번에 여러 개의 이미지를 열 수 있으며, 메뉴를 통해 이미지 간을 전환할 수도 있습니다.

이미지는 하드 드라이브에 있는 이미지의 복사본이기 때문에, 다음과 같은 저장 방법을 사용할 수 있습니다.

새로 만들기

새 이미지를 만듭니다. 저장을 누르면 하드 드라이브에 새 파일을 만듭니다.

열기…

기존 이미지의 복사본을 만듭니다. 저장을 누르면 작업 복사본으로 원본 이미지를 덮어씁니다.

기존 문서를 제목 없는 문서로 열기…

열기…와 비슷하지만 저장 시 위치를 물어 보며, 새 사본을 만듭니다. 이는 다른 프로그램의 menuselection:가져오기… 기능과 비슷합니다.

현재 이미지에서 복사본 만들기

기존 문서를 제목 없는 문서로 열기…와 비슷하지만, 현재 선택한 이미지에서 복사본을 만듭니다.

증분 버전 저장

버전 번호가 추가된 새 파일을 만들어 현재 이미지의 스냅샷을 만들 수 있습니다.

이러한 옵션은 파일 간의 빠른 전환이 필요하거나 극단적인 작업을 수행해서 백업 파일이 필요한 프로덕션 작업자에게 매우 유용합니다. 또한 Krita는 자동 저장, 파일 백업, 충돌 복구의 형태로 파일 백업 시스템을 갖고 있습니다. 일반 설정에서 이러한 기능에 대한 옵션을 설정할 수 있습니다.

보기를 통해 이미지를 봅니다.

보기

보기는 이미지의 창입니다. Krita에서는 보기 여러 개를 표시할 수 있는데, 이미지 자체를 편집하지 않고도 보기를 조작하여 이미지를 확대, 회전, 반전 또는 수정할 수 있습니다. 한 쪽으로 치우친 그림처럼 흔한 실수를 검사할 때 이미지를 보는 방법을 바꾸는 방법을 흔히 사용하므로, 예술가에게 유용한 기능입니다. M 키로 이미지를 반전시키면 이러한 왜곡을 쉽게 알 수 있습니다.

특정 곡선을 그리기 어렵다면 이미지를 회전시켜 그릴 수 있습니다. 물론 정밀하거나 거친 작업을 위한 확대/축소 기능도 사용할 수 있습니다.

../../_images/Krita_multiple_views.png

Krita에서 같은 이미지를 보기 여러 개로 보기

Krita에서는 창 ‣ 새 보기 ‣ 이미지 이름을 통해 여러 개의 보기로 보는 것이 가능합니다. 메뉴나 Ctrl + Tab 단축키를 사용해 여러 보기를 전환하거나, 설정에서 하위 창 모드가 활성화되어 있다면 창 –> 바둑판식 보기를 통해 동일한 영역에서 볼 수 있습니다.

도커

도커는 Krita의 인터페이스에 있는 하위 창입니다. 색상 선택기, 레이어 스택, 도구 옵션 등 유용한 도구를 포함합니다.

../../_images/Dockers.png

The image above shows some dockers in Krita.

모든 보기와 도커는 안에서만 열립니다.

이전에 컴퓨터를 사용해 본 적이 있다면 창이 무엇인지 알 수 있을 것입니다. 이는 컴퓨터 프로그램을 위한 커다란 컨테이너입니다.

Krita에서는 창 ‣ 새 창을 통해 창 여러 개를 열 수 있습니다. 다중 모니터를 사용한다면 다른 창을 다른 모니터로 드래그할 수 있습니다.

아래 이미지는 Krita에 여러 창이 열린 예시입니다.

../../_images/Multi-window.png

Krita의 캔버스

Krita에서 새 문서를 만들었을 때 직사각형 형태의 흰 영역을 볼 수 있습니다. 이를 캔버스라고 합니다. 아래 이미지에서 붉은 사각형으로 표시된 영역이 캔버스입니다.

../../_images/Canvas-krita.png

이미지를 JPG, PNG 등으로 저장하거나 인쇄할 때에는 이 영역 내부의 내용만을 고려합니다. 영역 밖에 있는 것은 무시됩니다. Krita는 캔버스 외부 영역의 정보를 저장하지만 단지 볼 수 없을 뿐입니다. 이 데이터는 레이어에 저장됩니다.

레이어와 합성

풍경화를 그릴 때 가장 먼저 하늘을 그리고 멀리 있는 요소들을 먼저 칠하듯이, 컴퓨터 또한 그리려고 하는 모든 것을 똑같이 그릴 것입니다. 같은 자리에 사각형 다음에 원을 그릴 경우 그 원은 항상 나중에 그려집니다. 이를 레이어 순서라고 합니다.

레이어 스택은 레이어 요소를 분리하고 어떤 레이어에 어떤 것이 그려지는지를 보여 줍니다. 레이어의 순서를 변경하고 그 밖의 모든 효과를 적용할 수 있습니다. 이를 합성이라고 합니다.

이를 통해 색채 위, 즉 산 앞에 있는 나무의 선화를 그릴 수 있고, 다른 그림의 영향을 받지 않고 각각을 편집할 수 있습니다.

Krita는 다양한 형식의 레이어를 지원하며, 각각 레이어마다 고유한 사용 목적이 있습니다.

칠하기 레이어

이 레이어는 래스터 레이어이며, Krita에서 가장 자주 사용되며 기본값으로 설정된 레이어입니다. 주로 이 레이어에 그림을 그립니다.

벡터 레이어

벡터 그래픽을 그리는 레이어입니다. 일반적으로 벡터 그래픽은 래스터 그래픽보다 단순하며, 변형을 할 때 이미지가 흐려지지 않는다는 이점이 있습니다.

그룹 레이어

드래그 앤 드롭을 통해 여러 레이어를 그룹화할 수 있습니다. 그룹으로 묶인 구성, 이동, 마스크 적용 및 기타 작업을 함께 수행합니다.

복제 레이어

레이어를 만들 때 선택한 레이어의 복사본입니다. 원본 레이어를 변경할 때 자동으로 업데이트됩니다.

파일 레이어

Krita 외부의 기존 이미지를 참조하며, 외부 이미지가 업데이트 되는 즉시 함께 업데이트됩니다. 로고나 엠블럼처럼 자주 바뀌는 이미지에 유용합니다.

채우기 레이어

이 레이어는 특정한 색깔이나 무늬처럼 Krita가 즉석에서 만들 수 있는 것으로 채워져 있습니다.

필터 레이어

이 레이어는 해당 레이어 아래에 있는 레이어로 만든 합성 이미지에 영향을 주는 필터를 적용합니다.

도구를 이용해 레이어의 내용을 변경할 수 있습니다.

도구

도구를 이용해 이미지 데이터를 변경할수 있습니다. 가장 흔한 것은 자유형 브러시로, Krita를 열었을 때 기본적으로 선택되어 있습니다. Krita에는 다섯 가지 도구 종류가 있습니다.

칠하기 도구

페인트 레이어에 그림을 그리는 도구입니다. 직사각형, 원, 직선과 같은 모양뿐만 아니라 자유형 경로를 그릴 수 있습니다. 브러시 엔진에서는 이러한 모양을 사용하여 모양과 그리기 효과를 만듭니다.

벡터 도구

벡터 편집에 사용하는 도구입니다. 자유형 브러시를 제외한 모든 칠하기 도구는 벡터 레이어에도 사용할 수 있습니다. 해당 도구를 사용하면 일반 레이어에 칠하기 도구를 사용한 것과는 다르게 외곽선에 브러시 사전 설정을 사용하지 않습니다.

선택 도구

다른 항목에 영향을 주지 않고 작업 중인 레이어의 특정 영역을 편집할 수 있습니다. 선택 도구를 사용하여 현재 선택 영역을 그리거나 수정할 수 있습니다. 이는 전통적인 그림을 그리는 방법 중 마스킹 액체(masking-fluids)를 사용하는 것과 같지만, 마스킹 액체와 필름을 사용하는 것에 비해 훨씬 섬세하고 사용하기 편합니다.

안내선 도구

격자나 도우미와 같은 도구입니다.

변형 도구

캔버스에서 레이어나 객체를 변환할 때 사용하는 도구입니다.

모든 도구는 도구 상자에서 찾을 수 있으며, 각각 도구에 대한 정보는 매뉴얼의 도구 섹션에서 확인할 수 있습니다.

브러시 엔진

브러시 엔진은 앞에서 말한 바와 같이 선이 지나는 경로와 태블릿의 정보를 취하여 스트로크를 만드는 역할을 합니다.

Krita에서 엔진은 어떠한 기능의 핵심이며 다양하게 설정할 수 있는 상호 작용 코드 세트를 설명할 때 사용하는 단어입니다. 즉, 자동차의 엔진이 자동차를 움직이고, 엔진의 종류와 구성이 차를 사용하는 방법에 영향을 미치듯이, 브러시 엔진은 브러시의 모습과 느낌을 결정합니다. 따라서 브러시 엔진이 달라지면 결과 또한 달라집니다.

Krita에는 서로 다른 효과를 구현하는 다양한 브러시 엔진이 있습니다.

../../_images/Krita_example_differentbrushengines.png

왼쪽: 픽셀 브러시, 가운데: 색상 번짐 브러시, 오른쪽: 스케치 브러시.

예를 들어 픽셀 브러시 엔진은 단순하고 기본적인 작업을 할 수 있지만, 그림을 많이 그릴 때에는 색상 번짐 브러시 엔진이 더 유용할 수도 있습니다. 픽셀 브러시 엔진보다 사용 속도가 느리지만 색상을 섞는 작업은 훨씬 빠르게 할 수 있기 때문입니다.

만약 아주 다른 것을 원한다면, 스케치 브러시 엔진은 지저분한 선을 연출하는 데에 도움이 되고, 모양 브러시 엔진은 큰 플랫을 빠르게 만들 수 있게 해 줍니다. Krita의 브러시 엔진에는 멋진 효과가 아주 많으니, 모두 시험해 보고 브러시 엔진별 설명을 꼭 확인해 보십시오.

이러한 효과는 F5 키를 이용해 접근하는 브러시 설정 드롭다운에서 설정할 수 있습니다. 여기에서 저장된 구성은 F6 키를 이용해 브러시 사전 설정 도커로 빠르게 접근할 수 있습니다.

브러시는 색으로 그려지지만, 컴퓨터는 이 색들을 어떻게 이해할까요?

색상

인간은 수백만 가지 색을 볼 수 있습니다. 색은 표면에서 반사되어 나오는 빛의 조합으로, 물체의 표면에서는 그 일부만을 흡수합니다.

../../_images/Krita_basics_primaries.png

Subtractive CMY colors on the left and additive RGB colors on the right. This difference means that printers benefit from color conversion before printing.

전통적인 방식으로 그림을 그릴 때에는 원하는 색상의 물감을 사용합니다. 물감은 특정한 색상의 빛을 흡수하며, 물감을 섞을수록 빛이 많이 흡수되어 점점 어두운 검은색으로 변합니다. 그래서 우리는 물감의 혼합을 감산 혼합이라고 합니다. 물감을 많이 섞을수록 빛이 빠지기 때문입니다. 따라서 전통적인 물감 혼합을 할 때 가장 효율적인 색상은 시안(Cyan), 마젠타(Magenta), 노랑(Yellow)의 세 가지 색상(CMY)입니다.

컴퓨터 또한 삼원색을 사용하며 각각 색상을 원색의 혼합 비율로 저장합니다. 다만 컴퓨터 화면은 빛을 발산하므로, 여러 색상이 섞일수록 더 많은 빛이 더해져서 점점 흰색으로 변합니다. 이러한 방식을 가산 혼합이라고 합니다. 컴퓨터의 색상 혼합에 있어 가장 효율적인 색상이 빨강, 초록, 파랑(RGB)인 것도 이러한 이유입니다.

컴퓨터는 픽셀당 원색의 값을 저장하며, 색 농도에 따라서 최댓값이 달라집니다. 프로그램이나 문서에 따라서 구성 요소채널이라는 이름으로 불립니다.

../../_images/Krita_basic_channel_rose.png

이 그림은 붉은 장미 그림의 빨간색 채널입니다. 보이는 바와 같이 꽃잎이 흰색인데, 이 부위에 빨간색이 가득 들어 있음을 나타냅니다. 잎 부분은 훨씬 어두운데, 녹색이기 때문에 빨간색이 들어 있지 않음을 나타냅니다.

기본적으로 컴퓨터는 RGB를 사용하지만 CMYK(감산 모델) 또는 LAB과 같은 지각 모델로 변환할 수도 있습니다. 이는 단지 색상이 서로 어떻게 연관되어 있는지를 나타내는 방법일 뿐이며, 따라서 일반적으로 3개의 구성 요소를 갖습니다. 여기서 예외적인 것은 그레이스케일인데, 그레이스케일은 컴퓨터가 얼마나 흰색을 갖고 있는지 만을 기억하면 되기 때문입니다. 따라서 그레이스케일은 메모리 측면에서 효율적입니다.

실제로 각 채널을 따로 보면 그레이스케일 이미지로도 보이지만, 사실 흰색은 빨간색, 녹색, 파란색이 얼마나 있는지만을 나타낼 뿐입니다.

Krita는 매우 복잡한 색 관리 시스템을 갖고 있습니다. 이에 관해서는 이 문서에서 더 자세히 읽을 수 있습니다.

투명도

빨간색, 녹색, 파란색과 마찬가지로, 컴퓨터는 픽셀이 얼마나 투명한지를 저장할 수 있습니다. 이는 앞에서 언급한 합성에 매우 중요합니다. 투명하지 않다면 여러 레이어를 갖는 것이 의미가 없기 때문입니다.

투명도는 색상과 같은 방식으로 저장되는데, 투명도도 하나의 채널이라는 것을 의미합니다. 보통 이러한 채널을 알파 채널이라고 부르거나, 줄여서 알파라고 부릅니다. 알파라고 불리는 이유는 프로그래밍에서 ‘α’라는 글자로 나타내기 때문입니다.

일부 오래된 프로그램은 기본적으로 투명도를 사용하지 않지만, Krita는 그와 반대입니다. 투명도 정보가 없는 이미지에는 항상 투명도 채널을 추가합니다. 주어진 픽셀이 모든 레이어에서 완전히 투명하다면 Krita는 위에 있는 장미 그림처럼 체커보드 패턴을 표시합니다.

혼합 모드

색은 숫자로 저장되기 때문에 색에 수학적인 계산을 할 수 있습니다. 이를 혼합 모드 또는 합성 모드라고 부릅니다.

혼합 모드는 레이어당, 또는 브러시 스트로크당 수행될 수 있습니다. 따라서 레이어 합성의 일부라고 할 수 있습니다.

곱하기

일반적으로 사용되는 혼합 모드는 곱하기입니다. 구성 요소를 곱하여 어두운 색상으로 만들며, 이를 통해 감산 혼합을 시뮬레이션하여 그림자를 쉽게 그릴 수 있습니다.

더하기

또 다른 흔한 혼합 모드는 더하기입니다. 한 층의 구성 요소를 다른 층에 첨가하여 빛이 나는 효과를 내기에 제격입니다.

지우기

지우기는 Krita에만 있는 혼합 모드입니다. 지우개 도구는 없지만 E 키로 빠르게 전환하면 지우개가 됩니다. 레이어에서도 사용할 수 있습니다. 다른 혼합 모드와 달리 지우개는 알파 채널에만 영향을 주어 사물을 투명하게 만듭니다.

평균

평균 혼합 모드에서는 맨 위의 색상이 얼마나 투명한지에 따른 색상 간의 평균을 산출합니다.

Krita는 이외에도 서로 다른 혼합 모드가 총 76개 있습니다. 자세한 내용은 혼합 모드 페이지를 참조하십시오.

채널을 그레이스케일 이미지로 볼 수 있기 때문에, 반대로 그레이스케일 이미지를 채널로 변환할 수도 있습니다. 그레이스케일 이미지를 투명도로 사용하는 것이 그 예시이며, 이를 마스크라고 부릅니다.

마스크

마스크는 레이어에 적용되는 하위 효과의 일종으로, 일반적으로 그레이스케일 이미지로 나타냅니다.

자주 사용되는 마스크 중에는 그레일스케일 이미지를 사용하여 투명도를 지정하는 투명도 마스크가 있습니다. 투명도 마스크에서 검은색은 모든 것을 투명하게, 흰색은 완전히 불투명하게 만듭니다.

브러시를 사용하여 마스크에 페인트를 칠하거나 일반 페인트를 마스크로 변환할 수도 있습니다. 마스크의 가장 큰 장점은 아래에 있는 픽셀을 제거하지 않고도 사물을 투명하게 만들 수 있다는 점이며, 이를 이용해 전체 그룹 레이어를 한번에 드러내거나 숨길 수도 있습니다.

예를 들어, 여기 새하얀 유령이 있습니다.

../../_images/Krita_ghostlady_1.png

하지만 이 사람이 정말 유령인지 아니면 그냥 하얀 사람인지 알 수 없습니다. 유령이 허공에 떠 있다는 느낌을 주기 위해 레이어에 마우스 오른쪽 단추를 클릭하여 투명도 마스크를 추가합니다. 이후 마스크를 선택하고 검은색과 흰색의 선형 그라데이션을 그려 검은색이 아래로 가도록 합니다.

../../_images/Krita_ghostlady_2.png

검은색이 어디에 있든 간에, 이제 이 유령은 투명해져서 정말 귀신처럼 보입니다!

마스크라는 이름은 전통적인 마스킹 액체와 필름에서 유래되었습니다. 이전에 언급했던 선택 영역과 마스킹 액체에 대한 비유를 다시 생각해 볼 수도 있습니다. 선택 영역도 내부적으로는 그레이스케일 이미지로 저장되며 마스크의 일종인 로컬 선택 영역으로 저장하거나 투명도 마스크로 변환할 수 있습니다.

필터

앞서 혼합 모드를 설명하며 수학적인 계산을 할 수도 있다고 언급했습니다. 하지만 픽셀이나 픽셀 그룹뿐만 아니라, 전체 레이어를 사용한 계산을 할 수도 있습니다. Krita에서는 여러 종류의 작은 계산을 여러 레이어에 걸쳐서도 할 수 있습니다. 이 작업을 필터라고 부릅니다.

작업의 예시는 다음과 같습니다.

채도 감소

모든 픽셀을 회색으로 만듭니다.

흐림

이웃한 픽셀의 평균치를 산출하여 날카로운 대비를 없애고 전체 이미지를 흐릿하게 보이게 합니다.

선명하게

픽셀 간의 대비를 증가시킵니다.

색상을 알파로

선택한 모든 색을 투명하게 만드는 필터로, 자주 쓰이는 필터 중 하나입니다.

../../_images/Krita_basic_filter_brush.png

이미지의 다른 부분에 각각 다른 필터 브러시를 사용한 예시입니다.

Krita에서 사용할 수 있는 필터에 대해 더 알아보려면 이 문서를 참조하십시오.

Filter Brush Engine

대부분의 작업은 픽셀 단위로 적용되기 때문에, Krita는 필터를 필터 브러시 엔진의 일부로 사용할 수 있습니다.

대부분의 이미지 편집 소프트웨어에서 필터는 별도의 도구이지만, Krita는 브러시 엔진을 사용하기 때문에 다른 소프트웨어보다 더 많은 부분을 변경할 수 있습니다.

픽셀을 무채색으로 바꾸거나 색조를 바꾸는 브러시도 만들 수 있다는 의미입니다.

필터 레이어, 필터 마스크, 레이어 스타일

Krita는 필터 레이어필터 마스크를 통해 필터를 레이어 스택에 포함시킬 수 있습니다. 필터 레이어는 동일한 계층 구조 내에서 해당 레이어 아래의 모든 레이어에 영향을 미칩니다. 투명도와 필터 레이어에 적용한 투명도 마스크는 레이어가 적용되는 위치에 영향을 미칩니다.

반면 마스크는 단일 레이어에만 영향을 주며, 그레이스케일 이미지로 결정됩니다. 그룹에 적용할 경우 투명도 마스크와 마찬가지로 그룹 내의 모든 레이어에 영향을 미칩니다.

이 필터를 사용하여 유령을 더 으스스하게 보이게 할 수 있습니다. 유령 레이어를 선택한 후 복제 레이어를 만듭니다. 이후 마우스 오른쪽 단추를 클릭하고 필터 레이어를 추가하여 가우시안 흐림 효과를 10픽셀 내외로 지정합니다. 복제 레이어를 원래 레이어 뒤에 두고 혼합 모드를 ‘색상 닷지’로 설정해 으스스한 빛이 나는 것처럼 연출합니다. 원래 레이어에 계속 그림을 그릴 수 있으며, 계속 모든 것이 자동으로 업데이트됩니다!

../../_images/Krita_ghostlady_3.png

레이어 효과나 레이어 스타일은 일반 마스크보다 빠르지만 다용도는 아닌, Photoshop에서 널리 사용되는 필터 마스크입니다. 레이어를 마우스 오른쪽 단추로 클릭한 후 ‘레이어 스타일’을 선택하여 사용합니다.

변환

변환은 이미지의 픽셀에서 수행되는 작업이라는 점에서 필터와 유사합니다. 일반적인 이미지와 레이어 단위 변환은 이미지와 레이어 최상위 메뉴에 있으며, 전체 이미지의 크기를 조정하거나 회전하고 뒤집을 수도 있습니다.

캔버스 크기에만 영향을 미치는 자르기 도구와 주어진 레이어만 이동하는 이동 도구도 있습니다. 이 이상의 변환이 필요한 경우 변형 도구를 사용하십시오.

../../_images/Krita_transforms_free.png

이 도구를 사용해 캔버스를 회전 및 크기를 조정하거나 원근법에 맞게 배치할 수 있습니다. 또한 휨, 유동화, 케이지와 같은 고급 변형 도구를 사용할 수 있습니다. 해당 도구를 사용하면 사용자 지정 포인트를 그리거나 변형 브러시처럼 자유로운 변환을 할 수 있습니다.

Deform Brush Engine

Like the filter brush engine, Krita also has a Deform Brush Engine, which allows you to transform with a brush. This deform is like a much faster version of the Liquefy transform tool mode, but in exchange, its results are of much lower quality.

../../_images/Krita_transforms_deformvsliquefy.png

Apple transformed into a pear with liquefy on the left and Deform brush on the right.

또한 왜곡 브러시는 비파괴 마스크에는 적용할 수 없습니다.

Transform Masks

Like filters, transforms can be applied as a non-destructive operation that is part of the layer stack. Unlike filter and transparency masks however, Transform Masks can’t be driven by a grayscale image, for technical reasons. You can use transform masks to deform clone and file layers as well.

Animation

../../_images/Introduction_to_animation_walkcycle_02.gif

From version 3.0 onwards, Krita got raster animation support. You can use the timeline, animation and onionskin dockers, plus Krita’s amazing variety of brushes to do raster based animations, export those, and then turn them into movies or GIFs.

도우미, 격자, 안내선

다양한 기술적인 기능만 보고 Krita가 그림을 그리는 프로그램이라는 사실을 잊을지도 모릅니다. Krita는 일러스트레이터가 전통적인 방식으로 작업할 때처럼 그리기를 쉽게 도와 주는 다양한 기능을 제공합니다.

../../_images/Krita_basic_assistants.png

Krita의 소실점 도우미 사용 예시입니다.

격자와 안내선 도커

캔버스 위에 격자 또는 안내선을 보여 주는 설정할 수 있는 매우 간단한 안내 도구입니다.

스냅

격자, 안내선, 확장, 직교, 이미지의 중심과 경계선 등 모든 종류의 물체에 스냅 기능을 사용할 수 있습니다.

도우미를 이용해 그림 그리기

태블릿에 자를 붙일 수는 없기 때문에 캔버스 위에 도우미를 대신 나타냅니다. 동심원, 원근법, 평행선, 쉽게 잊어버리지만 그리기 어려운 것들을 그리도록 도와주는 기능입니다. Krita를 사용하면 도구 옵션을 통해 이러한 옵션에도 스냅 기능을 사용할 수 있습니다.

안내선은 Krita의 네이티브 형식으로 저장되므로, 나중에 쉽게 작업을 다시 시작할 수 있습니다.

사용자 설정

최종 개념인 사용자 설정으로 이어집니다.

Krita의 작업 공간은 사용자의 취향에 따라서 도커를 재배열하고 구성을 저장할 수 있습니다. 오른쪽 상단에 있는 단추를 통해 접근할 수 있습니다.

또한 설정 ‣ 도구 모음 설정, 설정 ‣ Krita 설정… ‣ 단축키, 설정 ‣ Krita 설정… ‣ 캔버스 입력 설정 항목에서도 단축키 및 도구 모음을 설정할 수 있습니다.